0
Started

random pieces of note text missing when I print to PDF

Jonathan Morgan 2 years ago updated by Mariusz Zakrzewski 2 years ago 8

When I print my diagram as a PDF, the text in a note:


"SUMMARY: The core of this metadata model includes "data_set"s, different "data_table"s of that data set, and then for each table, the set of "variable"s it contains.  Variables exist independent of data tables, so the same variable definition can apply to multiple tables (over years where a survey remained the same, or across surveys with different names).  For each variable, you can specify a set of valid values.  You can also specify when two variables are related and basic information on how to translate between the two.  In addition, there is space to group data set collections (one of these groupings could be the set of tables included in a production process, for example) and variables independent of ("variable_group") or within ("table_variable_group") a table."


consistently turns into:


SUMMARY: The core of this metadata model includes "data_set"s, different
"data_table"s of that data set, and then for each table, the set of "variable"s it
contains. Variables exist independent tables, so same variable definition can apply
to multiple tables (over years where a survey remained same, or across surveys
with different names). For variable, you specify valid values. You also specify when
two variables are related basic information on how translate between two. In
addition, there is space group collections (one these groupings could be included in
production process, example) ("variable_group") within ("table_variable_group")
table.

Words from the original text are seemingly randomly missing, causing the text to turn into something that sounds like a garbled mess.  Any idea why this would be happening?  Is it something in my text that I might be able to alter to fix?


Thanks,


Jonathan Morgan

Under review

Hi,

I tried and failed to reproduce that bug. The note is exactly the same in pdf and in modeler. Have you tried exporting to pdf once, or it fails every time? Can you send me your model in Vertabelo-Xml or send me a link to the model?

Regards,

Mariusz Zakrzewski

Here is a link to the model: https://my.vertabelo.com/model/BHhd0oISb3h0yj70MW3dIBnWwHNdmUrk


I am trying to output it on a mac (macOS 10.13.5), using Firefox 60.0.2.  I can try other browsers, or other operating systems, if that would help.

Also, the problem occurs every time, I haven't checked to see if it is the exact same words being removed every time.  If you can't reproduce, I can do more digging.

Problem also occurs in Chrome on this mac - XML output contains full text where PDF does not.

There are quotation marks in the text - that might contribute?  But the text removed doesn't seem to have any relation to the position of the quotation marks.

Thank you for reaching out. I have reproduced it, and we are currently working on it