+9
Completed

Do not auto-create foreign key reference.

Kindler Chase 4 years ago • updated 4 years ago 6
When adding a reference, a FK is automatically generated. Can you provide an option to disable this behavior?

For example, I will typically create the tables with the keys defined per my own naming convention and then create the references. The current behavior is a new field is automatically added as a FK and has to be manually deleted. My colleagues who are using Vertabelo would like to see the current behavior either removed or an option on the model itself to disable the behavior.
GOOD, I'M SATISFIED
Appreciate you responding to user community feedback. Thanks!
Satisfaction mark by Kindler Chase 4 years ago
Under review
This is a desired behavior for great majority of our users. However, we'll discuss within our team giving an option to disable automatic creation of FK column. Thanks for sharing your thoughts.
I have to agree with Kindler Chase. I find the auto creation of column names is extremely frustrating. I generate my tables and then hook up references. I am then forced to have to delete the automatically created table column, and then change the reference columns (not necessarily in that order). I keep having a tendency to overlook these these extra columns all the time. It opens the door for mistakes in my model. For those of us who have our own naming convention, it creates extra work.

Thanks for taking this suggestion into sincere consideration. 
+1
I agree with Kindler Chase as well... I find this behavior extremely frustrating, and, indeed, I'm skeptical that a "great majority" of users will find the current behavior preferable, as your user base grows.  
Completed
It is done and on production.

You can find new option Autogenerate FK in Preferences section in My account page. This option allows you disable/enable automatic generating of FK columns.