auto-naming option

Kevin Tendey 7 years ago 0

Currently, when i had a relation between two table (0..*), i got a FK named table_column.

In my app, my table are in the plural and my app want a FK in the singular.

It could be interesting to have an option to switch between the actual configuration and a plural configuration.

Concretely, in my app, i have a Users table and automatically my FK is Users_id, my app want user_id.

i don't think i'm the only one to use a framework that has this naming convention.