0
Answered

[PostgreSQL] Add quotes to generated SQL table names and columns

john palat 4 years ago updated 4 years ago 2
PostgreSQL does not require double quotes around table names and identifiers, it will just lower case them. However, I want them to remain in a certain case in the database. For example, if I add a table Team, I want it to show up as Team, not team. The generated sql will not add any quotes to the name unless it's a reserved keyword. Is there a way for me to add this? I only found this: http://support.vertabelo.com/topic/529465-postgresql-script-generated-ignore-double-quota-set-schema-and-tablespace-name/


but I don't think it's related.




Also with FK, if I have Team_id as a column, it will become team_id in the database w/o quotes. Help?

Answer

+1
Answer
Answered
Just check the "Quote all SQL identifiers" checkbox in "SQL generation settings" section:




All table and column names will be in double quotes.
GOOD, I'M SATISFIED
10/10 would ask again
Satisfaction mark by john palat 4 years ago
+1
Answer
Answered
Just check the "Quote all SQL identifiers" checkbox in "SQL generation settings" section:




All table and column names will be in double quotes.