Reverse Engineering tool installation issues

Ashwini Bhoite 3 years ago updated by Daniel Sobotka 3 years ago 7

My java version is : openjdk version "11.0.2" 2019-01-15

and when I run the command

java --add-modules java.xml.bind -cp .;reverse-engineering.jar;ojdbc6.jar com.vertabelo.reverse.Main -url "jdbc:oracle:thin:@//localhost:1521/xe" -user USERNAME -password 
password1234 -o localhost_file

I get error : Error occurred during initialization of boot layer
java.lang.module.FindException: Module java.xml.bind not found

Is my java version not comaptible?

There is new version of Reverse Engineering tool, you can download it (depending on your system) from:

The new version does not require java on your computer. The README file contains instruction. It is Beta version. 

    Thank you Daniel! It worked, my database objects are now in Vertabelo, but I do not see that it created a diagram. I just see in the left pane that all the objects are loaded. There are some problems(errors and warnings) though. Do I need to manually fix the problems? And how will I see a diagram in the right pane? Do I need to create it by dragging the objects manuall?

    The working area in modeler view consist of left pane, center workspace and right pane. Left and right panes can be hidden.

    Double-click on a table in left pane should scroll to target table in the center workspace.

    The right pane contains settings and problems found in selected table.

    Thank you for your quick responses Daniel! Is it ok to use the beta version though? Will I face any issues later because I am  importing a live database model in Vertabelo.


    The new Beta version is improved with gui and embedded java version, reverse process is the same as in previous version.

    Importing live database is ok because tool operates on a schema not on a data.

    Ok, so I imported the postgreSQL database into Vertabelo. But I get errors for datatypes such as 'Geometry datatype is not supported by database engine'. But I know that PostgreSQL has Geometry datatype. How to resolve this error?


    We support only standard PostgreSQL types, the Geometry type is from Postgis extension.

    The warning does not block database modelling process.

    You can hide this type of warnings by:

    • click somwhere in diagram (uncheck any table)
    • in the Model Properties panel go to the Model validation settings
    • uncheck the Supported database type (warnings) option